<!DOCTYPE html><html lang="en"><head><title>Police calling man a hero for saving several people, dogs caught in blizzard conditions</title><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=307" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=307" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=307" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-kvvu-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=307"/><link rel="stylesheet" href="https://gray-kvvu-prod.cdn.arcpublishing.com/pf/resources/dist/kvvu/css/main.css?d=307"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css" rel="stylesheet"/><meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"/><link rel="icon" type="image/x-icon" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/favicon.ico?d=307"/><link rel="icon" type="image/png" sizes="16x16" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/favicon-16x16.png?d=307"/><link rel="icon" type="image/png" sizes="32x32" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/favicon-32x32.png?d=307"/><link rel="icon" type="image/png" sizes="48x48" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/favicon-48x48.png?d=307"/><link rel="apple-touch-icon" sizes="57x57" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-57x57.png?d=307"/><link rel="apple-touch-icon" sizes="60x60" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-60x60.png?d=307"/><link rel="apple-touch-icon" sizes="72x72" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-72x72.png?d=307"/><link rel="apple-touch-icon" sizes="76x76" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-76x76.png?d=307"/><link rel="apple-touch-icon" sizes="114x114" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-114x114.png?d=307"/><link rel="apple-touch-icon" sizes="120x120" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-120x120.png?d=307"/><link rel="apple-touch-icon" sizes="144x144" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-144x144.png?d=307"/><link rel="apple-touch-icon" sizes="152x152" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-152x152.png?d=307"/><link rel="apple-touch-icon" sizes="167x167" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-167x167.png?d=307"/><link rel="apple-touch-icon" sizes="180x180" href="//webpubcontent.gray.tv/gray/arc-fusion-assets/images/favicons/kvvu/apple-touch-icon-180x180.png?d=307"/><link rel="amphtml" href="https://www.fox5vegas.com/2022/12/30/police-calling-man-hero-saving-several-people-dogs-caught-blizzard-conditions/?outputType=amp"/><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2022 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=547736528"/><meta name="google-play-app" content="app-id=com.mylocaltv.kvvudroid"/><meta name="burst" content="kvvu"/><meta property="og:url" content="https://www.fox5vegas.com/2022/12/30/police-calling-man-hero-saving-several-people-dogs-caught-blizzard-conditions/"/><link rel="canonical" href="https://www.fox5vegas.com/2022/12/30/police-calling-man-hero-saving-several-people-dogs-caught-blizzard-conditions/"/><meta name="robots" content="index,follow,noarchive"/><meta name="googlebot" content="index"/><meta name="googlebot-news" content="index"/><meta itemProp="description" name="description" content="Authorities in New York state are calling a man a hero for rescuing several people who got stuck in blizzard conditions over the holiday weekend."/><meta property="og:description" content="Authorities in New York state are calling a man a hero for rescuing several people who got stuck in blizzard conditions over the holiday weekend."/><meta name="twitter:description" content="Authorities in New York state are calling a man a hero for rescuing several people who got stuck in blizzard conditions over the holiday weekend."/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="120520000000000"/><meta property="article:publisher" content="https://www.facebook.com/FOX5Vegas/"/><meta name="keywords" content="Cheektowaga Police Department,Cheektowaga Police Department christmas jay,Cheektowaga Christmas jay,Cheektowaga police Christmas jay,Cheektowaga Christmas jay rescue,Christmas jay rescue,Police calling man a hero for saving several people, dogs caught in blizzard conditions,Police calling man a hero for saving several people caught in blizzard conditions,Police calling man a hero for saving several people caught in blizzard,christmas jay note,Pine Hill School,Pine Hill School shelter"/><meta name="news_keywords" content="Cheektowaga Police Department,Cheektowaga Police Department christmas jay,Cheektowaga Christmas jay,Cheektowaga police Christmas jay,Cheektowaga Christmas jay rescue,Christmas jay rescue,Police calling man a hero for saving several people, dogs caught in blizzard conditions,Police calling man a hero for saving several people caught in blizzard conditions,Police calling man a hero for saving several people caught in blizzard,christmas jay note,Pine Hill School,Pine Hill School shelter"/><meta itemProp="image" property="og:image" content="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/GYJsOt1vae_xmSPI5rFiJ0HqB9A=/1200x600/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/PQODWXOU7VAWDAXWDLOGLSR2VQ.png"/><meta name="twitter:image" content="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/GYJsOt1vae_xmSPI5rFiJ0HqB9A=/1200x600/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/PQODWXOU7VAWDAXWDLOGLSR2VQ.png"/><meta property="og:site_name" content="https://www.fox5vegas.com"/><meta property="og:title" content="Police calling man a hero for saving several people, dogs caught in blizzard conditions"/><meta name="twitter:title" content="Police calling man a hero for saving several people, dogs caught in blizzard conditions"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@fox5vegas"/><meta name="twitter:creator" content="@fox5vegas"/><meta property="article:section" content="National"/><meta property="article:sections_paths" content="/news/national"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "Fox 5 Las Vegas",
  "url": "https://www.fox5vegas.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.fox5vegas.com//webpubcontent.gray.tv/gray/arc-fusion-assets/images/logo-off-site/kvvu.png?d=307"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/FOX5Vegas/",
    "https://www.instagram.com/fox5vegas/",
    "https://www.twitter.com/fox5vegas/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Police calling man a hero for saving several people, dogs caught in blizzard conditions",
  "url": "https://www.fox5vegas.com/2022/12/30/police-calling-man-hero-saving-several-people-dogs-caught-blizzard-conditions/",
  "image": "https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/GYJsOt1vae_xmSPI5rFiJ0HqB9A=/1200x600/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/PQODWXOU7VAWDAXWDLOGLSR2VQ.png",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "description": "Authorities in New York state are calling a man a hero for rescuing several people who got stuck in blizzard conditions over the holiday weekend.",
  "keywords": [
    "Cheektowaga Police Department",
    "Cheektowaga Police Department christmas jay",
    "Cheektowaga Christmas jay",
    "Cheektowaga police Christmas jay",
    "Cheektowaga Christmas jay rescue",
    "Christmas jay rescue",
    "Police calling man a hero for saving several people, dogs caught in blizzard conditions",
    "Police calling man a hero for saving several people caught in blizzard conditions",
    "Police calling man a hero for saving several people caught in blizzard",
    "christmas jay note",
    "Pine Hill School",
    "Pine Hill School shelter"
  ],
  "headline": "Police calling man a hero for saving several people, dogs caught in blizzard conditions",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.fox5vegas.com/2022/12/30/police-calling-man-hero-saving-several-people-dogs-caught-blizzard-conditions/"
  },
  "author": {
    "@type": "Person",
    "name": "Jordan Gartner"
  },
  "publisher": {
    "name": "Fox 5 Las Vegas",
    "url": "https://www.fox5vegas.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.fox5vegas.com//webpubcontent.gray.tv/gray/arc-fusion-assets/images/logo-off-site/kvvu.png?d=307"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2022-12-30T01:49:25.601Z",
  "datemodified": "2022-12-30T01:49:25.601Z"
}</script><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CObject.fromEntries%2CArray.prototype.entries"></script><script type="text/javascript" src="https://gray-kvvu-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=307"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://childlikeform.com/v2yucyy83xvSqosAtk1THaGQghTok6MJNtq48AorKxADQStnbuE1VrqIW7g",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o[n]=o[n]||t})(window,String.fromCharCode(97,100,109,105,114,97,108));!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");</script><script src="//c.amazon-adsystem.com/aax2/apstag.js"></script><script type="text/javascript">(function() {
  var purl = window.location.href;
  var url = '//ads.pubmatic.com/AdServer/js/pwt/161733/6819';
  var profileVersionId = '';
  if(purl.indexOf('pwtv=')>0){
      var regexp = /pwtv=(.*?)(&|$)/g
      var matches = regexp.exec(purl);
      if(matches.length >= 2 && matches[1].length > 0){
          profileVersionId = '/'+matches[1];
      }
  }
  var wtads = document.createElement('script');
  wtads.async = true;
  wtads.type = 'text/javascript';
  wtads.src = url+profileVersionId+'/pwt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(wtads, node);
})();
</script><script type="text/javascript">!(function () {window.PianoESPConfig = {id: 376,};var e = document.createElement("script");e.setAttribute("id", "pnesplucidsdksel"),(e.type = "text/javascript"),(e.src = "https://api-esp.piano.io/public/sdk/v04/sdk.js?v="+((localStorage && localStorage.lucidsdkver) || "xxx")),(e.async = !0),document.getElementsByTagName("script")[0].parentNode.appendChild(e);})();</script><script type="text/javascript" src="/pf/resources/js/analytics/comscore.js?d=307"></script><script type="text/javascript">
          var gdmComscore = ns_.analytics;
          gdmComscore.PlatformApi.setPlatformAPI(gdmComscore.PlatformApi.PlatformApis.WebBrowser)
          gdmComscore.configuration.addClient(new gdmComscore.configuration.PublisherConfiguration({'publisherId':"10477191"}))
          gdmComscore.configuration.setUsagePropertiesAutoUpdateMode(gdmComscore.configuration.UsagePropertiesAutoUpdateMode.FOREGROUND_AND_BACKGROUND);
          // gdmComscore.configuration.enableImplementationValidationMode();
          gdmComscore.start();
         </script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/news/national",
        authors: [ {
            _id:  "jordan-gartner",
            name:  "Jordan Gartner",
            type:  "author"
          }],
        canonicalUrl: "https://www.fox5vegas.com/2022/12/30/police-calling-man-hero-saving-several-people-dogs-caught-blizzard-conditions/",
        contentId: "NVOF7EI4MFB3JPEFDYLORBBW64",
        contentKewords: [ "Cheektowaga Police Department","Cheektowaga Police Department christmas jay","Cheektowaga Christmas jay","Cheektowaga police Christmas jay","Cheektowaga Christmas jay rescue","Christmas jay rescue","Police calling man a hero for saving several people, dogs caught in blizzard conditions","Police calling man a hero for saving several people caught in blizzard conditions","Police calling man a hero for saving several people caught in blizzard","christmas jay note","Pine Hill School","Pine Hill School shelter"],
        contentName: "Police calling man a hero for saving several people, dogs caught in blizzard conditions",
        contentOwner: "dcc-gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "12/29/2022",
        distributorCategory: "staff",
        distributorMode: "reference_denormalized",
        distributorName: "Digital Content Center (DCC)",
        distributorReferenceId: "ee793078-3533-42e7-922c-c8e01dcb900e",
        distributorSubCategory: "gray-original-content",
        hasVideo: false,
        metaDescription: "Authorities in New York state are calling a man a hero for rescuing several people who got stuck in blizzard conditions over the holiday weekend.",
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/news/national",
          name:  "National",
          path:  "/news/national"
        },
        publishedDay: "29",
        publishedMonth: "12",
        publishedYear: "2022",
        stationName: "kvvu",
        subtype: "default",
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: (new Date()).toString(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script><script>
    (function() {
      var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
      _sf_async_config.uid = 39189;
      _sf_async_config.domain = "fox5vegas.com";
      _sf_async_config.useCanonical = true;
      _sf_async_config.useCanonicalDomain = true;
      _sf_async_config.authors = "Jordan Gartner";
      _sf_async_config.type = "story";
      _sf_async_config.sections = "/news/national";
      _sf_async_config.flickerControl = false;
    })();
  </script><script async="" data-integration="chartbeat" src="//static.chartbeat.com/js/chartbeat.js"></script><script async="" src="//static.chartbeat.com/js/chartbeat_mab.js"></script><div id="fusion-static-enter:553c0a750c8a4cc3-script-reference" style="display:none" data-fusion-component="553c0a750c8a4cc3-script-reference"></div><script defer="" data-integration="queryly" src="https://www.queryly.com/js/queryly.v4.min.js"></script><script>window.addEventListener('DOMContentLoaded', (event) => {
            queryly.init("553c0a750c8a4cc3", document.querySelectorAll("#fusion-app"));
          });</script><div id="fusion-static-exit:553c0a750c8a4cc3-script-reference" style="display:none" data-fusion-component="553c0a750c8a4cc3-script-reference"></div><div id="fusion-static-enter:taboola-header-reference" style="display:none" data-fusion-component="taboola-header-reference"></div><script>     window._taboola = window._taboola || [];     _taboola.push({ article: "auto" });     !(function (e, f, u, i) {        if (!document.getElementById(i)) { e.async = 1; e.src = u; e.id = i; f.parentNode.insertBefore(e, f); }     })(        document.createElement("script"),        document.getElementsByTagName("script")[0],        "//cdn.taboola.com/libtrc/meredith-network/loader.js",        "tb_loader_script"     );     if (window.performance && typeof window.performance.mark == "function") { window.performance.mark("tbl_ic"); }</script><div id="fusion-static-exit:taboola-header-reference" style="display:none" data-fusion-component="taboola-header-reference"></div>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"false","rua.upre":"false","rua.cpre":"false","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(e){var n="https://s.go-mpulse.net/boomerang/";if("False"=="True")e.BOOMR_config=e.BOOMR_config||{},e.BOOMR_config.PageParams=e.BOOMR_config.PageParams||{},e.BOOMR_config.PageParams.pci=!0,n="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="HNFAR-5KB7Y-C34UC-HKJ57-R9Q7C",function(){function e(){if(!o){var e=document.createElement("script");e.id="boomr-scr-as",e.src=window.BOOMR.url,e.async=!0,i.parentNode.appendChild(e),o=!0}}function t(e){o=!0;var n,t,a,r,d=document,O=window;if(window.BOOMR.snippetMethod=e?"if":"i",t=function(e,n){var t=d.createElement("script");t.id=n||"boomr-if-as",t.src=window.BOOMR.url,BOOMR_lstart=(new Date).getTime(),e=e||d.body,e.appendChild(t)},!window.addEventListener&&window.attachEvent&&navigator.userAgent.match(/MSIE [67]\./))return window.BOOMR.snippetMethod="s",void t(i.parentNode,"boomr-async");a=document.createElement("IFRAME"),a.src="about:blank",a.title="",a.role="presentation",a.loading="eager",r=(a.frameElement||a).style,r.width=0,r.height=0,r.border=0,r.display="none",i.parentNode.appendChild(a);try{O=a.contentWindow,d=O.document.open()}catch(_){n=document.domain,a.src="javascript:var d=document.open();d.domain='"+n+"';void(0);",O=a.contentWindow,d=O.document.open()}if(n)d._boomrl=function(){this.domain=n,t()},d.write("<bo"+"dy onload='document._boomrl();'>");else if(O._boomrl=function(){t()},O.addEventListener)O.addEventListener("load",O._boomrl,!1);else if(O.attachEvent)O.attachEvent("onload",O._boomrl);d.close()}function a(e){window.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!window.BOOMR||!window.BOOMR.version&&!window.BOOMR.snippetExecuted){window.BOOMR=window.BOOMR||{},window.BOOMR.snippetStart=(new Date).getTime(),window.BOOMR.snippetExecuted=!0,window.BOOMR.snippetVersion=12,window.BOOMR.url=n+"HNFAR-5KB7Y-C34UC-HKJ57-R9Q7C";var i=document.currentScript||document.getElementsByTagName("script")[0],o=!1,r=document.createElement("link");if(r.relList&&"function"==typeof r.relList.supports&&r.relList.supports("preload")&&"as"in r)window.BOOMR.snippetMethod="p",r.href=window.BOOMR.url,r.rel="preload",r.as="script",r.addEventListener("load",e),r.addEventListener("error",function(){t(!0)}),setTimeout(function(){if(!o)t(!0)},3e3),BOOMR_lstart=(new Date).getTime(),i.parentNode.appendChild(r);else t(!1);if(window.addEventListener)window.addEventListener("load",a,!1);else if(window.attachEvent)window.attachEvent("onload",a)}}(),"".length>0)if(e&&"performance"in e&&e.performance&&"function"==typeof e.performance.setResourceTimingBufferSize)e.performance.setResourceTimingBufferSize();!function(){if(BOOMR=e.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var n=""=="true"?1:0,t="",a="eow65cqxbsityy5okcca-f-d25395195-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,o={"ak.v":"34","ak.cp":"1267003","ak.ai":parseInt("760927",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"6813ca07","ak.r":36534,"ak.a2":n,"ak.m":"dscr","ak.n":"ff","ak.bpcip":"35.173.238.0","ak.cport":57446,"ak.gh":"23.32.17.60","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1672368260","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==Lx4tJI/mrakZzsz7229AbqGL6vXjEdDrweCNnXd2llCzFLV7mM6W1O8Cvcq3adHIEvDCw+ohUwtsjrR0GzLWYQ4tI3Aq1FBHsoHXG218lJr0hXFiYNmOOekSQYczmPw/graYDgjNQU0LqsSZqIkDWQ7lg8GwyqxRyT3rw67UniHnH41kbH2Z/YPc+DlNFzsu4VhVaJgndz++J/sNbCU9cIwnbKGw3YVarvvlFo4BPG1p0OAg+uxpbNcXClAoPpA3jS/Z8lZ9VqpOSerUQDR4feBpoCMd3Hy6w0cFWV/O1YPNsplO8vxO3YyGBMT/hmtMH6oG2NIy/4t3SiM3bcmD+w1q58RbtFjOMo3h+EVayZFVzElS4dwJpU+R9GM8b3emQUeGf0y8f8x6QrWNQOFbp98P5qUKl349FHInTRr2QuM=","ak.pv":"13","ak.dpoabenc":"","ak.tf":i};if(""!==t)o["ak.ruds"]=t;var r={i:!1,av:function(n){var t="http.initiator";if(n&&(!n[t]||"spa_hard"===n[t]))o["ak.feo"]=void 0!==e.aFeoApplied?1:0,BOOMR.addVar(o)},rv:function(){var e=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(e)}};BOOMR.plugins.AK={akVars:o,akDNSPreFetchDomain:a,init:function(){if(!r.i){var e=BOOMR.subscribe;e("before_beacon",r.av,null,null),e("onbeacon",r.rv,null,null),r.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/kvvu.jpg?d=307&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/kvvu.svg?d=307&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/kvvu.svg?d=307&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news/crime">Crime</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/traffic">Traffic</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/politics">Politics</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/content/lifestyle">MORE</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/livestream">Watch Live</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/community/surprise-squad">Surprise Squad</a></li><li class="navbar-link | navbar-item d-none d-xl-flex"><a class="nav-link text-white" href="/community/take-5">Take 5 to Care</a></li><li class="navbar-link | navbar-item d-none d-xl-flex"><a class="nav-link text-white" href="/community/superbuild-playground">Super Build Playground</a></li></ul><label aria-label="Toggle search bar" class="queryly-nav-toggle pointer m-0 py-1 px-2" for="queryly_toggle"><i class="d-block fas fa-search"></i></label></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Homepage</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/traffic">Traffic</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/user-content">Submit Photos &amp; Video</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/politics">Politics</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Politics navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics/election-results">Election Results</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/health/coronavirus">COVID-19</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/video-gallery/news/">Video</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Video navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/livestream">Live Newscasts</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/video-gallery/news/fox5-experts">FOX5 Experts</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/video-gallery/news/behind-the-badge">Behind the Badge</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/video-gallery/pets/pet-pals">Pet Pals</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/content/news/education">School Watch</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/superbuild">Super Build Home</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/rant">The Rant</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/video-gallery/news/what-the-hall">What the Hall?</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/nfl/las-vegas-raiders">Las Vegas Raiders</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/nhl/golden-knights">Vegas Golden Knights</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/ncaa/unlv">Reb Zone</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/radar">Radar</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/weather-specials">Weather Specials</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/surprise-squad">Surprise Squad</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/superbuild">Super Build Home Edition</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/superbuild-playground">Super Build Playground</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/shining-star">Shining Star</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/take-5">Take 5 to Care</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/content/lifestyle">MORE</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the MORE navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.facebook.com/MOREFOX5" rel="noopener noreferrer" target="_blank">MORE on Facebook</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/lifestyle/spin-zone">Findlay Celebrity Spin Zone</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/vegas-huddle-podcast/">Vegas Huddle Podcast</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/dry-heat-podcast">Dry Heat with Mike Davis</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/contests">Contests</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us">About Us</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the About Us navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/contact-us">Contact Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/apps">FOX5 App</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/meet-the-team">Meet the Team</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://gray.tv/careers#currentopenings" rel="noopener noreferrer" target="_blank">Careers</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/programming/schedule">Programming Schedule</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://publicfiles.fcc.gov/tv-profile/kvvu-tv" rel="noopener noreferrer" target="_blank">FCC Information</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/closed-captioning">Closed Captioning</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="http://www.circleallaccess.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music and Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com/" rel="noopener noreferrer" target="_blank">Gray DC Bureau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.fox5vegas.com/powernation" rel="noopener noreferrer" target="_blank">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/publishers/310/kvvu/" rel="noopener noreferrer" target="_blank">Latest Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sponsored/sponsor-spotlight">Sponsor Spotlight</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit KVVU on FACEBOOK" class="p-2" href="https://www.facebook.com/FOX5Vegas" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit KVVU on INSTAGRAM" class="p-2" href="https://www.instagram.com/fox5vegas" rel="noopener noreferrer" target="_blank"><i class="fab fa-instagram fa-2x"></i></a><a aria-label="Visit KVVU on TWITTER" class="p-2" href="https://www.twitter.com/fox5vegas" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a><a aria-label="Visit KVVU on YOUTUBE" class="p-2" href="https://www.youtube.com/channel/UCpR_4YnLJAphcr0VI5yR5SA" rel="noopener noreferrer" target="_blank"><i class="fab fa-youtube fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"></div></nav><section class="leaderboard | w-100"><div class="arc-ad | d-flex flex-column ad-type-flex-leaderboard ad-flex-leaderboard include-disclaimer justify-content-center text-center"><div class="arc-ad-wrapper |"><div id="ad-mfYwWH90fDzC" class="kvvu/web/news/national arcad py-2 mt-3 mb-3"></div></div></div></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Police calling man a hero for saving several people, dogs caught in blizzard conditions</span></h1></div><div class="lead-art | col-12"><figure class="image | figure mb-0 constrained image-ratio-16x9"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="Police in New York state are praising the actions of a man who they say saved several people..." height="675" src="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/ibtuJ-DKEB89tJekcF4Af7t5yak=/1200x675/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/PQODWXOU7VAWDAXWDLOGLSR2VQ.png" width="1200"/></div><figcaption class="figure-caption">Police in New York state are praising the actions of a man who they say saved several people caught in blizzard conditions.<span class="ml-2">(Cheektowaga Police Department)</span></figcaption></figure></div><div class="byline | col-12"><div class="authors |"><span class="">By<!-- --> </span><span class="author |"><a class="text-decoration-none" href="/authors/jordan-gartner/">Jordan Gartner</a></span><span></span></div></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published<!-- -->: <!-- -->Dec. 29, 2022 at 5:49 PM PST</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated<!-- -->: <!-- -->43 minutes ago</span></div><div class="sharebar |  col-12"><div class="btn p-0 facebook" role="button"><svg class="icon |  facebook pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Facebook</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.991 3.657 9.128 8.438 9.878v-6.987h-2.54V12h2.54V9.797c0-2.506 1.492-3.89 3.777-3.89 1.094 0 2.238.195 2.238.195v2.46h-1.26c-1.243 0-1.63.771-1.63 1.562V12h2.773l-.443 2.89h-2.33v6.988C18.343 21.128 22 16.991 22 12c0-5.523-4.477-10-10-10" fill-rule="evenodd"></path></svg></div><div class="btn p-0 mail" role="button"><svg class="icon | mail pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Email This Link</title><path d="M3.313 5.273C3.493 5.103 3.734 5 4 5h16c.13 0 .253.025.366.07L11.79 12.49 3.313 5.273zM21 7.166V18a1 1 0 0 1-1 1H4a1 1 0 0 1-1-1V7.775l8.064 6.867c.376.32.945.305 1.338-.036L21 7.166z" fill-rule="nonzero"></path></svg></div><div class="btn p-0 twitter" role="button"><svg class="icon | twitter pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Twitter</title><path d="M8.29 20.251c7.547 0 11.675-6.253 11.675-11.675 0-.178 0-.355-.012-.53A8.35 8.35 0 0 0 22 5.92a8.189 8.189 0 0 1-2.357.646 4.117 4.117 0 0 0 1.804-2.27 8.222 8.222 0 0 1-2.605.996 4.107 4.107 0 0 0-6.993 3.743 11.65 11.65 0 0 1-8.457-4.287 4.106 4.106 0 0 0 1.27 5.477A4.073 4.073 0 0 1 2.8 9.713v.052a4.105 4.105 0 0 0 3.292 4.022 4.095 4.095 0 0 1-1.853.07 4.108 4.108 0 0 0 3.834 2.85A8.233 8.233 0 0 1 2 18.407a11.617 11.617 0 0 0 6.29 1.84" fill-rule="evenodd"></path></svg></div><div class="btn p-0 pinterest" role="button"><svg class="icon | pinterest pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Pinterest</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.239 2.634 7.86 6.354 9.317-.09-.79-.165-2.008.033-2.873.18-.781 1.169-4.97 1.169-4.97s-.297-.602-.297-1.482c0-1.391.807-2.428 1.811-2.428.856 0 1.267.642 1.267 1.407 0 .856-.543 2.14-.83 3.334-.24.995.501 1.81 1.48 1.81 1.778 0 3.145-1.876 3.145-4.576 0-2.395-1.72-4.066-4.181-4.066-2.848 0-4.519 2.132-4.519 4.338 0 .856.33 1.777.74 2.28.083.098.091.189.067.288-.074.312-.247.995-.28 1.135-.041.181-.148.223-.338.132-1.25-.584-2.033-2.403-2.033-3.876 0-3.153 2.289-6.05 6.61-6.05 3.465 0 6.164 2.47 6.164 5.778 0 3.449-2.173 6.222-5.185 6.222-1.012 0-1.967-.527-2.288-1.152l-.626 2.379c-.222.872-.83 1.958-1.242 2.625.938.288 1.926.444 2.963.444 5.522 0 10-4.477 10-10A9.98 9.98 0 0 0 12 2" fill-rule="evenodd"></path></svg></div><div class="btn p-0 linkedin" role="button"><svg class="icon | linkedin pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on LinkedIn</title><path d="M4.329 3H19.67C20.405 3 21 3.595 21 4.329V19.67c0 .734-.595 1.329-1.329 1.329H4.33A1.329 1.329 0 0 1 3 19.67V4.329C3 3.595 3.595 3 4.329 3zM18.35 17.901v-5.316c0-2.626-1.632-3.522-3.142-3.522-1.396 0-2.31.904-2.572 1.433h-.035V9.305H10V17.9h2.706v-4.66c0-1.243.787-1.847 1.59-1.847.76 0 1.349.427 1.349 1.812v4.695h2.706zM7.56 8.107c.86 0 1.56-.656 1.56-1.553C9.12 5.656 8.42 5 7.56 5 6.697 5 6 5.656 6 6.554c0 .897.698 1.553 1.56 1.553zm-1.354 9.788h2.706V9.298H6.207v8.597z" fill-rule="evenodd"></path></svg></div></div></div></section><section class="body | w-100"><div class="article-body | article w-100"><p class="text | article-text">CHEEKTOWAGA, N.Y. (Gray News) - Authorities in New York state are calling a man a hero for rescuing several people who got stuck in blizzard conditions over the holiday weekend.</p><p class="text | article-text">According to the <a href="https://www.facebook.com/CheektowagaPD/posts/pfbid02PmyDNvJ7T5u8R3NPc3ddj1SFySFDp2bbJMU5VJtfC7xDiAAuyFyv4eVbic3vkqSwl" target="_blank">Cheektowaga Police Department</a>, a man named Jay left a note behind at Pine Hill School over Christmas weekend after breaking into the school.</p><p class="text | article-text">Authorities said Jay apologized in the note for the break-in but said he needed to borrow a snowblower to help clear a path to get people inside and out of the deadly blizzard conditions.</p><p class="text | article-text">The police department <a href="https://www.facebook.com/CheektowagaPD/posts/pfbid02PmyDNvJ7T5u8R3NPc3ddj1SFySFDp2bbJMU5VJtfC7xDiAAuyFyv4eVbic3vkqSwl" target="_blank">shared</a> images from the school’s security cameras that captured Jay’s actions that evening.</p><div class="w-100" style="height:90px"></div><p class="text | article-text">According to police, Jay wrote in his note that he had gotten stuck at 8 p.m. on Dec. 23 and slept in his truck with two strangers just trying not to die.</p><p class="text | article-text">The man noted that seven older people also got stuck and were out of fuel that night. Police said Jay shared that he had to break into the school to save everyone and get them shelter, along with food and a bathroom.</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="Police in New York state are praising the actions of a man who they say saved several people..." height="1063" src="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/to8G3wvkM_6deHZHWdZui2Qann8=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/5R3UAJS355BS3LTBZM26LJGS2M.png" width="980"/></div><figcaption class="figure-caption">Police in New York state are praising the actions of a man who they say saved several people caught in blizzard conditions.<span class="ml-2">(Cheektowaga Police Department)</span></figcaption></figure><p class="text | article-text">Officers said they were initially alerted about an alarm at the school but couldn’t respond due to the dangerous weather conditions.</p><div class="w-100" style="height:90px"></div><p class="text | article-text">Police noted that once they entered the school, they found a freezer still fully stocked with food, and everything that the group used was returned to the same spot it was found.</p><p class="text | article-text">Police said the group appeared to eat and use equipment just enough for them to survive. Additionally, two dogs were able to take shelter that evening.</p><p class="text | article-text">Cheektowaga police said they first shared the <a href="https://www.facebook.com/CheektowagaPD/posts/pfbid02PmyDNvJ7T5u8R3NPc3ddj1SFySFDp2bbJMU5VJtfC7xDiAAuyFyv4eVbic3vkqSwl" target="_blank">rescue story</a> to help identify Jay and thank him for his actions.</p><p class="text | article-text">On Thursday, the department said the man was <a href="https://www.facebook.com/CheektowagaPD/posts/pfbid02MKES42rg5EZJsbrsG25NnVJGgrHrvatfUFQiJomhR3M8KAxy9xaWpvMPPSg3uzDol" target="_blank">identified</a> with the help of family and friends.</p><p class="text | article-text">Authorities said Jay and the group are now like family after surviving that evening and are planning a summer get-together.</p><p class="copyright |"><i>Copyright 2022 Gray Media Group, Inc. All rights reserved.</i></p></div></section><section class="recommendations | w-100"><div id="fusion-static-enter:taboola-widget-0ffvPqqxRrf" style="display:none" data-fusion-component="taboola-widget-0ffvPqqxRrf"></div><div class="taboola-feed | w-100 mb-3"><div id="taboola-below-article-thumbnails-new"></div><script>window._taboola = window._taboola || [];_taboola.push({"mode":"alternating-thumbnails-a","container":"taboola-below-article-thumbnails-new","placement":"Below Article Thumbnails New","target_type":"mix"});</script></div><div id="fusion-static-exit:taboola-widget-0ffvPqqxRrf" style="display:none" data-fusion-component="taboola-widget-0ffvPqqxRrf"></div></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"><div class="w-100" style="height:600px"></div><div class="w-100" style="height:600px"></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Latest News</span></h4></div><div class="card-deck mx-n2 mb-0"><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/12/30/retired-teacher-hits-125000-jackpot-playing-poker-las-vegas/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Officials say a retired teacher from Hawaii won a $125,000 jackpot while playing poker at a Las..." height="450" src="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/FLT-IgL98W_XLWCpP_EVKVcGuTU=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/VIQDL4HWOVBY5MFO4W36AXRBBI.png" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/12/30/retired-teacher-hits-125000-jackpot-playing-poker-las-vegas/" rel="" target="_self"><span>Retired teacher hits $125,000 jackpot playing poker in Las Vegas</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/12/29/vivienne-westwood-influential-fashion-maverick-dies-81/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="English designer Vivienne Westwood waves as she is applauded by her models at the end of the..." height="450" src="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/3PTozrl53TASavnxBpRu_Adugmc=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/EQFBUOVIPFD77NWCEQ3QUV2DAI.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/12/29/vivienne-westwood-influential-fashion-maverick-dies-81/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Vivienne Westwood, influential fashion maverick, dies at 81</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/12/30/lvmpd-man-found-stabbed-near-charleston-commerce/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="LVMPD: Man found stabbed near Charleston, Commerce" height="450" src="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/SdxCB-mEBsZYmuS3eoSRgNPBM7w=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/5GUG747VNFHALD6URNR2GRMSPM.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/12/30/lvmpd-man-found-stabbed-near-charleston-commerce/" rel="" target="_self"><span>LVMPD: Man found stabbed near Charleston, Commerce</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/12/29/biden-signs-17-trillion-bill-funding-government-operations/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="President Joe Biden arrives at Henry E. Rohlsen Airport, in St. Croix, U.S. Virgin Islands,..." height="450" src="https://gray-kvvu-prod.cdn.arcpublishing.com/resizer/0Tc6AHiBqbqHY3pVCnIyKmuldfo=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/NTNEWAWXUBEYBKI237K5SFDKBI.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/12/29/biden-signs-17-trillion-bill-funding-government-operations/" rel="" target="_self"><span>Biden signs $1.7 trillion bill funding government operations</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div></div></div><div class="w-100" style="height:250px"></div></section></div><section class="bottom-wrapped | col-12"><div class="w-100" style="height:250px"></div></section></div></div><footer class="footer | w-100"><div class="arc-ad | d-flex flex-column ad-type-flex-leaderboard ad-flex-leaderboard ad-footer-flex-leaderboard ad-fixed-bottom position-fixed zindex-higher w-100 justify-content-center text-center"><div class="arc-ad-wrapper |"><div class="ad-dismiss | text-white pointer position-absolute top absolute-right p-1" role="button"><i class="far fa-times-circle fa-sm"></i></div><div id="ad-f79pWxoPCEeA" class="kvvu/web/news/national arcad py-0 my-0"></div></div></div><div id="fusion-static-enter:footer-kvvu" style="display:none" data-fusion-component="footer-kvvu"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/homepage">Homepage</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/traffic">Traffic</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/content/lifestyle">MORE</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community/calendar">Community Calendar</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community/surprise-squad">Surprise Squad</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/programming/schedule">Programming Schedule</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/about-us/contact-us">Contact Us</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/page/apps">Download Our Apps!</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="https://lmgcorporate.com/adops/adspecs/adspecs.html" rel="noopener noreferrer" target="_blank">AdSpecs</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">KVVU</li><li class="footer-contact | footer-address">25 TV 5 Dr</li><li class="footer-contact | footer-city-state">Henderson, NV 89014</li><li class="footer-contact | footer-phone">(702) 435-5555</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service" rel="noopener noreferrer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/kvvu-tv" rel="noopener noreferrer" target="_blank">Public Inspection File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:rose.burbach@kvvu.com" rel="noopener noreferrer" target="_blank">rose.burbach@kvvu.com | 702-435-5555</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/kvvu-fcc_applications.pdf" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/api/manager/download/656185f5-2bc0-4aad-eddc-61f6a2c5706c/99ddc096-0d31-48e0-9ff3-9a80b869547e.pdf" rel="noopener noreferrer" target="_blank">EEO Report</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://gray.tv/careers#currentopenings" rel="noopener noreferrer" target="_blank">FOX5 Careers</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/page/closed-captioning" rel="noopener noreferrer" target="_blank">Closed Captioning/Audio Description</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising" rel="noopener noreferrer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2022 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-kvvu" style="display:none" data-fusion-component="footer-kvvu"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script><div id="fusion-static-enter:taboola-body-reference" style="display:none" data-fusion-component="taboola-body-reference"></div><script>
window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script><div id="fusion-static-exit:taboola-body-reference" style="display:none" data-fusion-component="taboola-body-reference"></div></body></html>